[ad_1]

Hello everyone, I am new here and was wondering if you could help me out with a problem I’m having with my truck.

I just bought this truck last month and it has been nothing, but problems. The truck is a 2008 Freightliner Colombia with a Detroit 60 series with 630k miles.

The problem I am having with the truck is:
1. wont perform auto regen.
2: will not finish a park regen.

I took the truck to a well known independent Detroit mechanic which was referred by couple of drivers in the area.

After diagnosis there was a code which he didn’t tell me but what i read on his computer was Doser fuel supply abnormal. then he told me that he needed to change the Doser and do a hard regen and it will be good to go.

After completing the repair I drove for approximately 350 mile and the check CEL comes on and another 20 mile the regen lite comes on.after driving for 50 min highway speed the regen light starts flashing and i pulled over and performed a park regen.The regen took 25min and the CEL didn’t go away.

After contacting the mechanic he offered to check out the truck once again so he can take a look at it. After I took it to him it said the same fault doser fuel supply abnormal and he said its the aluminum block which is the metering unit and DPF filter needs cleaning. He changed the metering unit and send out the DPF filter to get cleaned and put the truck back together and a hard regen,he said that I wont have any more problems.
After picking up the truck, today same thing happen. I tried to pull out fault codes from the dashboard and the codes are ECU128, SID 154, FAIL01. I don’t know what to do anymore. I would really appreciate your help.

Thank You,
Chris

 

[ad_2]

Source link